node-sass でOS X 64-bit with Unsupported runtimeと言われた時の対策

下記のようなエラーが出た

$ node-sass
/usr/local/lib/node_modules/node-sass/lib/binding.js:13
throw new Error(errors.unsupportedEnvironment());
^
Error: Node Sass does not yet support your current environment: OS X 64-bit with Unsupported runtime (64)
For more information on which environments are supported please see:
https://github.com/sass/node-sass/releases/tag/v4.5.0
at module.exports (/usr/local/lib/node_modules/node-sass/lib/binding.js:13:13)
at Object.<anonymous> (/usr/local/lib/node_modules/node-sass/lib/index.js:14:35)
at Module._compile (internal/modules/cjs/loader.js:678:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:689:10)
at Module.load (internal/modules/cjs/loader.js:589:32)
at tryModuleLoad (internal/modules/cjs/loader.js:528:12)
at Function.Module._load (internal/modules/cjs/loader.js:520:3)
at Module.require (internal/modules/cjs/loader.js:626:17)
at require (internal/modules/cjs/helpers.js:20:18)
at Object.<anonymous> (/usr/local/lib/node_modules/node-sass/bin/node-sass:11:10)

一度アンインストールしてから

npm uninstall -g node-sass

再度インストールしたら行けた

npm install -g node-sass

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA