UbuntuでRustのビルド時にerror: failed to run custom build command for `openssl-sys v0.9.40`とか言われる場合の対策

cargo test

と実行するとコンパイル中に下記のエラーが出て止まる。

error: failed to run custom build command for `openssl-sys v0.9.40`

libssl-devをインストールすれば解決する。

sudo apt install libssl-dev 

参考

https://qiita.com/nacika_ins/items/465e89a7b3fbeb373605

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA