RustでSerdeが使えない場合はcargoのバージョンが古い場合がある

下記のSerdeでコンパイルエラーが出ていました。

#[serde(deny_unknown_fields)]

公式によるとどうやらコンパイラが1.15が必要らしいのかな。

They require a Rust compiler version 1.15 or newer.

バージョン上げてみて解決しました

cargo update

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA