Ubuntuにluarocksを入れて5.3で動かす

Lua書くの久しぶり。最後に書いたのは4年前。それはApple信者時代だった。今はUbuntuユーザーです。

Ubuntuでは下記のようにしてLuaとluarocksがインストールしました。

5.3を入れるなら

sudo apt install luarocks-5.3

5.1を入れるなら

sudo apt install luarocks-5.1

luarocksはこれで入れられる。

sudo apt install luarocks

で、luarocks-5.3以上が必要な環境があってHomebrewで入れた時は luarocks-5.3 というコマンドがあったのでそれを使えば良かったが、Ubuntuでは環境に入れているluaのバージョンに左右されるみたいで、5.1が入っているとluarocksは5.1で動いていた。

sudo apt remove lua-5.1

と古いバージョンを除去することでluarocksのバージョンがあがった。aptでなんとかしようとした場合はこれなので、他の方法がありそうだね。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA